0

Empty Screen Launching Chromium-Browser Over X11 from Ubuntu 16 to OSX XQuartz

When trying to launch chromium-browser over ssh -X X11 from an Ubuntu Server to an OSX XQuartz client, I get the below error message and screenshot of an empty Chromium window.

X11 itself works, xcalc works fine, firefox works fine, but I need Chromium.

Any help would be greatly appreciated.

The Ubuntu Server is in VirtualBox, if it makes a difference. Brand new default 16.04.6 installation.

~$ chromium-browser --disable-gpu
[2106:2136:0110/131609.410497:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[2106:2136:0110/131609.746540:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[2106:2136:0110/131609.746581:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[2158:1:0110/131610.475709:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
[2158:1:0110/131610.476416:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.

1

Your Chromium build is trying to access some X11 extensions the XQuartz does not support.

Your best bet here is to use a nested X server so that server will support the functions locally.

If you are using a VM to do this, I recommend setting up VirGL as your rendering path instead. It is much faster.

EDIT BY OP:

我在天马彩票平台输了三十万Thank you for suggesting nested X server. This resolved my issue most quickly. I had never done such a thing before, so had to do a little research. Ultimately, my final steps were like this, with each SSH going from OSX Host running XQuartz to Ubuntu guest:

ssh -X vmname
sudo apt-get update
sudo apt-get -y install xnest
echo $DISPLAY
> localhost:10.0
Xnest :11
(leave this running)

Then in another session:

ssh vmname (note -X not necessary here)
DISPLAY=:11
export DISPLAY
chromium-browser

Your Answer

By clicking “Post Your Answer”, you agree to our , and

Not the answer you're looking for? Browse other questions tagged or ask your own question.